Вебинары Разобраться в IT Реферальная программа
Программирование Аналитика Дизайн Маркетинг
ПРИХОДИТЕ УЧИТЬСЯ НОВОЙ ПРОФЕССИИ ЛЕТОМ СО СКИДКОЙ ДО 70% Забронировать скидку
10 Июл 2023
2 мин
53

Обновление Eclipse с Android development tools v. 23

В процессе работы с Eclipse и Android development tools (ADT) часто возникают проблемы, связанные с обновлением. Например, после обновления SDK tools до версии 23, при запуске

В процессе работы с Eclipse и Android development tools (ADT) часто возникают проблемы, связанные с обновлением. Например, после обновления SDK tools до версии 23, при запуске Eclipse появляется следующее сообщение об ошибке:

Этот Android SDK требует версии Android Developer Toolkit 23.0.0 или выше. Текущая версия - 22.6.3.v201404151837-1123206. Обновите ADT до последней версии.

Однако, при попытке проверки наличия обновлений — обновлений не находится. Попытка установки нового программного обеспечения также не увенчивается успехом, поскольку возникает следующая ошибка:

Не удается завершить установку из-за конфликтующей зависимости.
Устанавливаемое программное обеспечение: Android Development Tools 23.0.0.1245622
Уже установленное программное обеспечение: Android Developer Tools 22.2.1.v201309180102-833290
Одновременно может быть установлен только один из следующих пакетов:
    ADT Package 22.6.3.v201404151837-1123206
    ADT Package 23.0.0.1245622
Не удается удовлетворить зависимость:
    От: Android Development Tools 23.0.0.1245622
    К: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Не удается удовлетворить зависимость:
    От: Android Development Tools 22.6.3.v201404151837-1123206
    К: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Не удается удовлетворить зависимость:
    От: ADT Package 22.2.1.v201309180102-833290
    К: com.android.ide.eclipse.adt.feature.group 22.2.0
Не удается удовлетворить зависимость:
    От: Android Developer Tools 22.2.1.v201309180102-833290
    К: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

После загрузки последней версии ADT с веб-сайта, похоже, возникает еще одна проблема.

С SDK Tools rev. 23 не устанавливается proguard, папка SDK dir/tools/proguard отсутствует, и отсутствуют и другие инструменты. Эта версия содержит несколько ошибок.

Эту проблему можно решить путем полного удаления текущей версии ADT и установки последней версии. Важно помнить, что вместе с обновлением ADT, следует обновить и Eclipse.

Добавить комментарий

Подарок
Забрать подарок